// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.edu(?:\.\w{2,3})?$").unwrap();
let string = ".xx
school.edu.au
college.edu.uk
.edu
school.edu
student.college.edu";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}