re = /\.edu(?:\.\w{2,3})?$/m
str = '.xx
school.edu.au
college.edu.uk
.edu
school.edu
student.college.edu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end