$re = '/\.edu(?:\.\w{2,3})?$/m';
$str = '.xx
school.edu.au
college.edu.uk
.edu
school.edu
student.college.edu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);