#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=\[*)(、)(?=.*\])"
Local $sString = "[FL-clover、door、(天満春華)]返せ,かわり、○○で。(東方)" & @CRLF & _
"[sadas、sadsad、]" & @CRLF & _
"" & @CRLF & _
"[sadas、sadsad、asdsad、]" & @CRLF & _
"" & @CRLF & _
"\[.*\]" & @CRLF & _
"" & @CRLF & _
"[FL-clover、door、(天満春華)]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")