re = /(?=\[*)(、)(?=.*\])/m
str = '[FL-clover、door、(天満春華)]返せ,かわり、○○で。(東方)
[sadas、sadsad、]
[sadas、sadsad、asdsad、]
\\[.*\\]
[FL-clover、door、(天満春華)]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end