using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\[*)(、)(?=.*\])";
string input = @"[FL-clover、door、(天満春華)]返せ,かわり、○○で。(東方)
[sadas 、sadsad、]
[sadas、sadsad、asdsad、]
\[.*\]
[FL-clover、door、(天満春華)]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}