$re = '/(?=\[*)(、)(?=.*\])/m';
$str = '[FL-clover、door、(天満春華)]返せ,かわり、○○で。(東方)
[sadas、sadsad、]
[sadas、sadsad、asdsad、]
\\[.*\\]
[FL-clover、door、(天満春華)]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);