import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\[*)(、)(?=.*\\])";
final String string = "[FL-clover、door、(天満春華)]返せ,かわり、○○で。(東方)\n"
+ "[sadas、sadsad、]\n\n"
+ "[sadas、sadsad、asdsad、]\n\n"
+ "\\[.*\\]\n\n"
+ "[FL-clover、door、(天満春華)]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}