#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?U)/catalogo-diam/(.+)-en-(.+)/$"
Local $sString = "/catalogo-diam/trios/trio-de-boda-en-oro-14k-con-diamantes-tdiam-003/"
Local $sSubst = "/producto/$1-$2/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)