import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"/catalogo-diam/(.+)-en-(.+)/$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/catalogo-diam/trios/trio-de-boda-en-oro-14k-con-diamantes-tdiam-003/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/producto/$1-$2/"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}