use strict;
my $str = '/catalogo-diam/trios/trio-de-boda-en-oro-14k-con-diamantes-tdiam-003/';
my $regex = qr~/catalogo-diam/(.+)-en-(.+)/$~p;
my $subst = '/producto/$1-$2/';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";