$re = '~/catalogo-diam/(.+)-en-(.+)/$~U';
$str = '/catalogo-diam/trios/trio-de-boda-en-oro-14k-con-diamantes-tdiam-003/';
$subst = "/producto/$1-$2/";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;