package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)/catalogo-diam/(.+)-en-(.+)/$`)
var str = []byte(`/catalogo-diam/trios/trio-de-boda-en-oro-14k-con-diamantes-tdiam-003/`)
var substitution = []byte("/producto/$1-$2/")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}