using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d[\d,]*\s*(?:(?:-|or)\s*\d[\d,]*\s*)?\p{L}+";
string input = @"50,001 - 100,000 積分
50,001 - 100,000 points";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}