$re = '/\d[\d,]*\s*(?:(?:-|or)\s*\d[\d,]*\s*)?\p{L}+/';
$str = '50,001 - 100,000 積分
50,001 - 100,000 points';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);