const regex = /\d[\d,]*\s*(?:(?:-|or)\s*\d[\d,]*\s*)?\p{L}+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d[\\d,]*\\s*(?:(?:-|or)\\s*\\d[\\d,]*\\s*)?\\p{L}+', 'g')
const str = `50,001 - 100,000 積分
50,001 - 100,000 points`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}