re = /\d[\d,]*\s*(?:(?:-|or)\s*\d[\d,]*\s*)?\p{L}+/
str = '50,001 - 100,000 積分
50,001 - 100,000 points'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end