package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d[\d,]*\s*(?:(?:-|or)\s*\d[\d,]*\s*)?\p{L}+`)
var str = `50,001 - 100,000 積分
50,001 - 100,000 points`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}