using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b-\d{1,3}-\d{1,3}-\d{1,3}(?::\d)?";
string input = @"r-1-1-1
r-1-1-1:3
-1-1-1
-1-1-1:3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}