$re = '/\b-\d{1,3}-\d{1,3}-\d{1,3}(?::\d)?/m';
$str = 'r-1-1-1
r-1-1-1:3
-1-1-1
-1-1-1:3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);