re = /\b-\d{1,3}-\d{1,3}-\d{1,3}(?::\d)?/m
str = 'r-1-1-1
r-1-1-1:3
-1-1-1
-1-1-1:3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end