package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b-\d{1,3}-\d{1,3}-\d{1,3}(?::\d)?`)
var str = `r-1-1-1
r-1-1-1:3
-1-1-1
-1-1-1:3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}