#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z1-9]+@[A-Za-z1-9]+\.[A-Za-z]{3}$"
Local $sString = "XxTheDarkOnexX@gmail.com" & @CRLF & _
"XxTheDarkOnexX+banking@gmail.com" & @CRLF & _
"sarahsmith85@gmail.com" & @CRLF & _
"sarah.smith.85@gmail.com" & @CRLF & _
"sarahsmith85@britain.co.uk" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")