package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z1-9]+@[A-Za-z1-9]+\.[A-Za-z]{3}$`)
var str = `XxTheDarkOnexX@gmail.com
XxTheDarkOnexX+banking@gmail.com
sarahsmith85@gmail.com
sarah.smith.85@gmail.com
sarahsmith85@britain.co.uk
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}