re = /^[A-Za-z1-9]+@[A-Za-z1-9]+\.[A-Za-z]{3}$/m
str = 'XxTheDarkOnexX@gmail.com
XxTheDarkOnexX+banking@gmail.com
sarahsmith85@gmail.com
sarah.smith.85@gmail.com
sarahsmith85@britain.co.uk
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end