import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z1-9]+@[A-Za-z1-9]+\\.[A-Za-z]{3}$";
final String string = "XxTheDarkOnexX@gmail.com\n"
+ "XxTheDarkOnexX+banking@gmail.com\n"
+ "sarahsmith85@gmail.com\n"
+ "sarah.smith.85@gmail.com\n"
+ "sarahsmith85@britain.co.uk\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}