const regex = /^[A-Za-z1-9]+@[A-Za-z1-9]+\.[A-Za-z]{3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z1-9]+@[A-Za-z1-9]+\\.[A-Za-z]{3}$', 'gm')
const str = `XxTheDarkOnexX@gmail.com
XxTheDarkOnexX+banking@gmail.com
sarahsmith85@gmail.com
sarah.smith.85@gmail.com
sarahsmith85@britain.co.uk
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}