using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\bcase\b\s*[\s\S]*?)\Kbreak(\(|\s|;?)[1-9]?(\)?)+;)|((?:\bdefault\b\s*[\s\S]*?)\Kbreak(\(|\s|;?)[1-9]?(\)?)+;)";
string input = @"<?php
switch
($this) {
case 'value':
echo ""test"";
break;
case 'deux':
echo 'deux';
$f;
break;
default:
// code...
break;
}
for
($i=0; $i < 10; $i++) {
$i ++;
break;
}
?>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}