re = /((?:\bcase\b\s*[\s\S]*?)\Kbreak(\(|\s|;?)[1-9]?(\)?)+;)|((?:\bdefault\b\s*[\s\S]*?)\Kbreak(\(|\s|;?)[1-9]?(\)?)+;)/m
str = '<?php
switch
($this) {
case \'value\':
echo "test";
break;
case \'deux\':
echo \'deux\';
$f;
break;
default:
// code...
break;
}
for
($i=0; $i < 10; $i++) {
$i ++;
break;
}
?>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end