$re = '/((?:\bcase\b\s*[\s\S]*?)\Kbreak(\(|\s|;?)[1-9]?(\)?)+;)|((?:\bdefault\b\s*[\s\S]*?)\Kbreak(\(|\s|;?)[1-9]?(\)?)+;)/m';
$str = '<?php
switch
($this) {
case \'value\':
echo "test";
break;
case \'deux\':
echo \'deux\';
$f;
break;
default:
// code...
break;
}
for
($i=0; $i < 10; $i++) {
$i ++;
break;
}
?>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);