#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\[|,)(?P<keep_whitespace>\s*\")(?P<fix>(?:[^\"]+)(?:\",?(?!\n)[^\",]*)+[^\"]*)(?=\"(?:,\n|\s*\]))"
Local $sString = "{" & @CRLF & _
" "Equipment Contents": [" & @CRLF & _
" "XL APPEARANCE GROUP"," & @CRLF & _
" "body-color grille"," & @CRLF & _
" "15" d"eep-"dish cast aluminum "wheels"," & @CRLF & _
" "15" d"eep-"dish cast aluminum "wheels"," & @CRLF & _
" "15" d"eep-"dish cast aluminum "wheels"," & @CRLF & _
" "15", 16", and 17" wheels"," & @CRLF & _
" "body-color body-side molding with chrome insert"," & @CRLF & _
" "luggage rack"," & @CRLF & _
" "15" deep-dish cast aluminum wheels"," & @CRLF & _
" "P235/75R15SL all-terrain OWL tires"," & @CRLF & _
" "power door locks"," & @CRLF & _
" "power windows"," & @CRLF & _
" "power mirrors"," & @CRLF & _
" "cloth captains chairs"," & @CRLF & _
" "15" d"eep-"dish cast aluminum wheels"" & @CRLF & _
" ]" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)