import Foundation
let pattern = #"(?<=\[|,)(?P<keep_whitespace>\s*\")(?P<fix>(?:[^\"]+)(?:\",?(?!\n)[^\",]*)+[^\"]*)(?=\"(?:,\n|\s*\]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"Equipment Contents": [
"XL APPEARANCE GROUP",
"body-color grille",
"15" d"eep-"dish cast aluminum "wheels",
"15" d"eep-"dish cast aluminum "wheels",
"15" d"eep-"dish cast aluminum "wheels",
"15", 16", and 17" wheels",
"body-color body-side molding with chrome insert",
"luggage rack",
"15" deep-dish cast aluminum wheels",
"P235/75R15SL all-terrain OWL tires",
"power door locks",
"power windows",
"power mirrors",
"cloth captains chairs",
"15" d"eep-"dish cast aluminum wheels"
]
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)