$re = '/(?<=\[|,)(?P<keep_whitespace>\s*\")(?P<fix>(?:[^\"]+)(?:\",?(?!\n)[^\",]*)+[^\"]*)(?=\"(?:,\n|\s*\]))/m';
$str = '{
"Equipment Contents": [
"XL APPEARANCE GROUP",
"body-color grille",
"15" d"eep-"dish cast aluminum "wheels",
"15" d"eep-"dish cast aluminum "wheels",
"15" d"eep-"dish cast aluminum "wheels",
"15", 16", and 17" wheels",
"body-color body-side molding with chrome insert",
"luggage rack",
"15" deep-dish cast aluminum wheels",
"P235/75R15SL all-terrain OWL tires",
"power door locks",
"power windows",
"power mirrors",
"cloth captains chairs",
"15" d"eep-"dish cast aluminum wheels"
]
}
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;