# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\[|,)(?P<keep_whitespace>\s*\")(?P<fix>(?:[^\"]+)(?:\",?(?!\n)[^\",]*)+[^\"]*)(?=\"(?:,\n|\s*\]))"
test_str = ("{\n"
" \"Equipment Contents\": [\n"
" \"XL APPEARANCE GROUP\",\n"
" \"body-color grille\",\n"
" \"15\" d\"eep-\"dish cast aluminum \"wheels\",\n"
" \"15\" d\"eep-\"dish cast aluminum \"wheels\",\n"
" \"15\" d\"eep-\"dish cast aluminum \"wheels\",\n"
" \"15\", 16\", and 17\" wheels\",\n"
" \"body-color body-side molding with chrome insert\",\n"
" \"luggage rack\",\n"
" \"15\" deep-dish cast aluminum wheels\",\n"
" \"P235/75R15SL all-terrain OWL tires\",\n"
" \"power door locks\",\n"
" \"power windows\",\n"
" \"power mirrors\",\n"
" \"cloth captains chairs\",\n"
" \"15\" d\"eep-\"dish cast aluminum wheels\"\n"
" ]\n"
"}\n\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.