const regex = new RegExp('(?<=\\[|,)(?P<keep_whitespace>\\s*\\")(?P<fix>(?:[^\\"]+)(?:\\",?(?!\\n)[^\\",]*)+[^\\"]*)(?=\\"(?:,\\n|\\s*\\]))', 'gm')
const str = `{
"Equipment Contents": [
"XL APPEARANCE GROUP",
"body-color grille",
"15" d"eep-"dish cast aluminum "wheels",
"15" d"eep-"dish cast aluminum "wheels",
"15" d"eep-"dish cast aluminum "wheels",
"15", 16", and 17" wheels",
"body-color body-side molding with chrome insert",
"luggage rack",
"15" deep-dish cast aluminum wheels",
"P235/75R15SL all-terrain OWL tires",
"power door locks",
"power windows",
"power mirrors",
"cloth captains chairs",
"15" d"eep-"dish cast aluminum wheels"
]
}
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);