import re
regex = re.compile(r"((?:ithelpdesk(?:|\d+)|deskserverithelp|itservicedeskhelp|ithelpservice(?:|\d+))@gmail.com)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("ithelpdesk458@gmail.com\n\n"
"ithelpdesk@gmail.com\n\n"
"deskserverithelp@gmail.com\n\n"
"itservicedeskhelp@gmail.com\n\n\n\n\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)