re = /((?:ithelpdesk(?:|\d+)|deskserverithelp|itservicedeskhelp|ithelpservice(?:|\d+))@gmail.com)/im
str = 'ithelpdesk458@gmail.com
ithelpdesk@gmail.com
deskserverithelp@gmail.com
itservicedeskhelp@gmail.com
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result