# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/f\[([^]]*)\]/f.__getitem__($1, x=x)/gm;t' <<< "f[r@ndom t3xt] + [some r@ndom t3xt] + [f[more r@ndom t3xt] / f[more t3xt]]
f[] + [] + [f[] / f[]]"