package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)f\[([^]]*)\]`)
var str = `f[r@ndom t3xt] + [some r@ndom t3xt] + [f[more r@ndom t3xt] / f[more t3xt]]
f[] + [] + [f[] / f[]]`
var substitution = "f.__getitem__($1, x=x)"
fmt.Println(re.ReplaceAllString(str, substitution))
}