re = /f\[([^]]*)\]/m
str = 'f[r@ndom t3xt] + [some r@ndom t3xt] + [f[more r@ndom t3xt] / f[more t3xt]]
f[] + [] + [f[] / f[]]'
subst = 'f.__getitem__($1, x=x)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result