using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)\s+(\d+)([A-Z]*)\s*,\s*(\d+\s+[A-Z]+)\s*,?\s*(.*?)\s*,\s*(.*)\s*";
string input = @"teststreet 1C, 1234 AZ New York, Australia
Jh. teststreet 1B, 9870 GH Amsterdam, Canada
teststreet 45, 9867 HJ Rotterdam, Germany";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}