package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\s+(\d+)([A-Z]*)\s*,\s*(\d+\s+[A-Z]+)\s*,?\s*(.*?)\s*,\s*(.*)\s*`)
var str = `teststreet 1C, 1234 AZ New York, Australia
Jh. teststreet 1B, 9870 GH Amsterdam, Canada
teststreet 45, 9867 HJ Rotterdam, Germany`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}