re = /(.*)\s+(\d+)([A-Z]*)\s*,\s*(\d+\s+[A-Z]+)\s*,?\s*(.*?)\s*,\s*(.*)\s*/m
str = 'teststreet 1C, 1234 AZ New York, Australia
Jh. teststreet 1B, 9870 GH Amsterdam, Canada
teststreet 45, 9867 HJ Rotterdam, Germany'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end