const regex = new RegExp('(.*)\\s+(\\d+)([A-Z]*)\\s*,\\s*(\\d+\\s+[A-Z]+)\\s*,?\\s*(.*?)\\s*,\\s*(.*)\\s*', 'gm')
const str = `teststreet 1C, 1234 AZ New York, Australia
Jh. teststreet 1B, 9870 GH Amsterdam, Canada
teststreet 45, 9867 HJ Rotterdam, Germany`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}