// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)\s+(\d+)([A-Z]*)\s*,\s*(\d+\s+[A-Z]+)\s*,?\s*(.*?)\s*,\s*(.*)\s*").unwrap();
let string = "teststreet 1C, 1234 AZ New York, Australia
Jh. teststreet 1B, 9870 GH Amsterdam, Canada
teststreet 45, 9867 HJ Rotterdam, Germany";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}