package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^»][\d{1,}]$`)
var str = `login as: LOGIN
SERVER@00.00.00.000's password:
Last login: Thu May 23 15:51:49 2019 from 00.00.00.000
CREER AUTANT DE REPERTOIRES SOUS /NAME/NAME/NAME QU'IL Y A DE
COMMERCANTS GERES. LE NOM DOIT ETRE LE NO DE COMMERCANT.
CREER ENSUITE SOUS CHACUN D'EUX UN REPERTOIRE NAME/
<SERVER>ps -fu NAME | grep exe | echo «resultat=»\`wc -l\`
«resultat=»14
<SERVER>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}