$re = '/[^»][\d{1,}]$/m';
$str = 'login as: LOGIN
SERVER@00.00.00.000\'s password:
Last login: Thu May 23 15:51:49 2019 from 00.00.00.000
CREER AUTANT DE REPERTOIRES SOUS /NAME/NAME/NAME QU\'IL Y A DE
COMMERCANTS GERES. LE NOM DOIT ETRE LE NO DE COMMERCANT.
CREER ENSUITE SOUS CHACUN D\'EUX UN REPERTOIRE NAME/
<SERVER>ps -fu NAME | grep exe | echo «resultat=»`wc -l`
«resultat=»14
<SERVER>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);