import Foundation
let pattern = #"[^»][\d{1,}]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
login as: LOGIN
SERVER@00.00.00.000's password:
Last login: Thu May 23 15:51:49 2019 from 00.00.00.000
CREER AUTANT DE REPERTOIRES SOUS /NAME/NAME/NAME QU'IL Y A DE
COMMERCANTS GERES. LE NOM DOIT ETRE LE NO DE COMMERCANT.
CREER ENSUITE SOUS CHACUN D'EUX UN REPERTOIRE NAME/
<SERVER>ps -fu NAME | grep exe | echo «resultat=»`wc -l`
«resultat=»14
<SERVER>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)