const regex = /[^»][\d{1,}]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^»][\\d{1,}]$', 'gm')
const str = `login as: LOGIN
SERVER@00.00.00.000's password:
Last login: Thu May 23 15:51:49 2019 from 00.00.00.000
CREER AUTANT DE REPERTOIRES SOUS /NAME/NAME/NAME QU'IL Y A DE
COMMERCANTS GERES. LE NOM DOIT ETRE LE NO DE COMMERCANT.
CREER ENSUITE SOUS CHACUN D'EUX UN REPERTOIRE NAME/
<SERVER>ps -fu NAME | grep exe | echo «resultat=»\`wc -l\`
«resultat=»14
<SERVER>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}