use strict;
my $str = 'login as: LOGIN
SERVER@00.00.00.000\'s password:
Last login: Thu May 23 15:51:49 2019 from 00.00.00.000
CREER AUTANT DE REPERTOIRES SOUS /NAME/NAME/NAME QU\'IL Y A DE
COMMERCANTS GERES. LE NOM DOIT ETRE LE NO DE COMMERCANT.
CREER ENSUITE SOUS CHACUN D\'EUX UN REPERTOIRE NAME/
<SERVER>ps -fu NAME | grep exe | echo «resultat=»`wc -l`
«resultat=»14
<SERVER>
';
my $regex = qr/[^»][\d{1,}]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}